$re = '/([01]?[0-9]|2[0-3]):[0-5][0-9]/m';
$str = 'saat 12:30 gibi gelirsin
00:00
23:45
10:15
06:59';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);