re = /(?=\b\s+)\s/m
str = '{user name=b.oaks, config name=corp-epointsetting, private ip=10.42.7.207, client region=us, client ip=75.75.58.65, client version=5.0.0-87, device name=zz-777, client os version=microsoft windows 10 pro 64-bit, vpn type=device level vpn}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end