$re = '/(?<=watch\?v=|/videos/|/shorts/|/live/|embed\/|youtu.be\/|\/v\/|\/e\/|watch\?v%3D|watch\?feature=player_embedded&v=|%2Fvideos%2F|embed%2F|youtu.be%2F|%2Fv%2F)[^#\&\?\n]*/';
$str = 'https://www.youtube.com/live/jfKfPfyJRdk?si=w62kL85ADoUnGlOQ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);