$re = '/^([^.\n]*\.[^.\n]*\.)\d+(.*)/m';
$str = 'ABC.1.2.3
XYZ.2.2.1';
$subst = "$11$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;