$re = '/SUB-(\d{3})_CONDITION-([a-zA-Z]*)/m';
$str = 'SUB-123_CONDITION-blablaBLA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);