import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w+[ ]){0,5}(abc\\(1\\)\\([xy]\\))(?:[ ]\\w+){0,5}";
final String string = "the quick brown fox abc(1)(x)\n"
+ "cat with a black hat is abc(1)(x) the quick brown fox jumps over the lazy dog.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}