re = /\$status\['[^']+'\][^']*'\K[^\n]*/m
str = '$status[\'Совершенно_новое\'] = \'Brand_new<<\'\' New\'\'>>New\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end