import re
regex = re.compile(r"T\.((?:[a-z_]*\.)*[a-z_]*)(?![a-z_]*\(\))", flags=re.MULTILINE)
test_str = ("T.name.other_name.another_name\n"
"T.name.again_name.ect_name.last_name()\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")