package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^CM|^\+?-?\d+[DWMYQ]`)
var str = `-123M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}