re = /(9\d{2})([ \-]?)(5\d|6[0-5]|7\d|8[0-8]|9[0-2,4-9])([ \-]?)(\d{4})/m
str = '#Matches
901-50-9999
901519999
901-52-9999
901-53-9999
901629999
901-65-9999
901-75-9999
901-85-9999
901-92-9999
#No matches
901-66-9999
801-65-9999
901-89-9999
901-93-9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end