#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-z]:\\(?:[^\\:]+\\)*(?:[^:\\]+)\.\w+)"
Local $sString = ""\\test\test$\TEST.exe" %1" & @CRLF & _
""\\server\share\folder\myfile.exe" %1" & @CRLF & _
""\\server\share\myfile.exe" %1" & @CRLF & _
""\\123.123.123.123\share\folder\myfile.exe" --play %1" & @CRLF & _
""c:\folder\myfile.exe" --asdf %1" & @CRLF & _
""c:\Program Files (x86)\TeamViewer\TeamViewer_server.exe" --asdf "%1" asdf.exe" & @CRLF & _
""\\server\share\fo lder\myfile.exe" %1" & @CRLF & _
""\\server\share\myf ile.txt" %1" & @CRLF & _
""\\123.123.123.123\share\folder\my file.exe" %1" & @CRLF & _
""c:\folder\myfil e.exe" %1" & @CRLF & _
""c:\folder\myfile WithoutExtension" %1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")