$re = '/\s([0-9.]+)\sm²/m';
$str = ' dec 98.2 m² avx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);