using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<li\>(?:\n)*(?:.*)(?:\n)*\<\/li\>)";
string input = @"preceding text
<li>this is an item</li>
<li>this is another item</li>
following text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}