package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\h{4}\S+`)
var str = ` qwer
qwer
dfgh
t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}