#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<ns\d+:(?P<ws_name>.+?)(?:Response|\b)"
Local $sString = "<ns2:GetJobStatus" & @CRLF & _
"<ns10:JobIDResponse" & @CRLF & _
"<ns2:JobStatusResponse" & @CRLF & _
"<ns3:GetJobId" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")