re = /(?x)
#http:\/\/.*|https:\/\/.*
https?.*/m
str = 'http://website.com
https://website2.com
htt://website3.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end