re = /\b(?:(\w)(?!\1))+\b/m
str = 'mike is amaaazing avsjsjsjsjsjsjsncd hahahaha hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end