using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[\s]+)?(?:const|let|var|)?(?:[a-z0-9.]+(?:\.prototype)?)?(?:\s)?(?:[a-z0-9-_{}:\s]+\s?=)?\s?(?:[a-z0-9]+\s+\:\s+)?(?:function\s?)?(?:[a-z0-9_-]+)?\s?\(.*\)\s?(?:.+)?([=>]:)?\{(?:(?:[^}{]+|\{(?:[^}{]+|\{[^}{]*\})*\})*\}(?:\s?\(.*\)\s?\)\s?)?)?(?:\;)?$";
string input = @"/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
const a = {
apples() {
},
apples2 : function() {
},
apples3 : () => {
}
}
function(){}
function() {}
function() { }
function () { }
function (arg, asdf) { }
function (arg, asdf):Typings { }
function (arg, asdf):something<Else> { }
function () { }
const x = function () { }
const { x } = function () { }
const { x: asdf } = function () { }
const filterFn = () => {}
// won't grab
const filterFn = apples.filter(() => {});
// won't grab
const filterFn = apples.filter(function(){});
class Bla {
constructor() {
}
someMethod1() {
}
someMethod2() => {
}
get someMethod3() {
}
}
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
HoverBoard.prototype.getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
const getFormatValueIfExists = function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
var getFormatValueIfExists = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
window.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
something.else.x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
var x = null;
x = (prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
function getFormatValueIfExists(prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
function (prop, defaultValue) {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
(prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
};
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
}());
/**
* @function
* @description simple method that tries to retrieve a config value from the format
* if it exists, else it will return the second argument as the default value.
* @param {string} prop - the prop name to retrieve
* @param {any} defaultValue - the value to use if we can't extract from the format
* @returns {any} - the default value or extracted format value
*/
((prop, defaultValue) => {
try {
return typeof this.config.formats[this.name][prop] !== 'undefined' ? this.config.formats[self.name][prop] : defaultValue;
} catch (e) {
return defaultValue;
}
} (window) );
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}