$re = '/(?<=<h[1-6]>).*?(?=<\/h[1-6]>)/m';
$str = '<div>
<h2>Hello!</h2>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);