$re = '/(?<=e-)\d+/m';
$str = 'Some random text --- e-1-e-20-e-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);