import re
regex = re.compile(r"((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("low-18\n"
"-20\n"
"19\n"
"20<-40\n"
"41-70\n"
"71-high\n"
"71-higher\n"
"low-71-high\n"
"lower-71\n"
"high-low\n"
"low-high\n"
"other\n"
"71-turn")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")