$re = '/^([A-Za-z0-9]{8,})$/m';
$str = 'aaaaaaaa
AAAAAAAA
00000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);