#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\[[0-9a-fA-F]{6}\])?(?:[^\S\r\n]*(.+?))(?=\[[0-9a-fA-F]{6}\]|$)"
Local $sString = "[00B800][!] Green - [004DB8] Blue does not match!!" & @CRLF & _
"" & @CRLF & _
"[FFFFff][!] White" & @CRLF & _
"" & @CRLF & _
"[e60000][!] Red" & @CRLF & _
"" & @CRLF & _
"123456" & @CRLF & _
"" & @CRLF & _
"Test string, another test abcdef"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")