$re = '/^0(\d{1,2}(-\d{4}){2}|\d{3}(-\d{3}){2}|\d{2}-\d{3}-\d{4}|\d{3}-\d{2}-\d{4}|\d{4}-\d{1}-\d{4})$/m';
$str = '090-1111-1111
03-1111-1111
0120-111-111
042-111-1111
0436-11-1111
02222-2-2222
0333-333-33
033-333-333
01-1111-1111
0-11111-1111
02-11111-111
022-123-1231
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);