const regex = /^(?:[0-1])(?:[0-9])[0]+\z/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-1])(?:[0-9])[0]+\\z', '')
const str = `180000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}