import re
regex = re.compile(r"^(?:.*[\/\\])?(?<FileNameWithoutExtension>.*)\.(.*)$", flags=re.MULTILINE)
test_str = ("Taylor Swift - New Romantics.m4a\n"
"YT/Subto2mp3/Taylor Swift - New Terribly Romantics.m4a\n"
"Grow - Conan Blue (Official Video) has already been recorded in archive.m4a\n"
"PowerOptim Iol/Techno/(Official Video) Blue Burrow was already been recorded in archive - Bak.wm4\n"
"/Great Bun/Output Files/çè/Grow - Conan DARK (Official AUDIO) has already been recorded in archive.m4b\n"
"Matter Oil_9999.zip\n"
"Qpl$-pol.hrlp/perm.ui.pol/i op/doesn't matter.mp4\n"
"Small Laser4.m4a\n"
"manicur pliu/love is in the a°°_II+?§@R.txt\n"
"^Level09\\\\Power Pol\\energy.m4a\n"
"lollller_blllade 1987 (c)/super €/music_piece_.mp3\n"
"\\.\\.$./../../loli( u1990) _98.lop.pl/fil l/fill2asm.aile.asm.gz.zip\n"
"/Taylor Swift - New Romantics._m4a\n"
"\\$/Subto2/mp3/Taylor Swift -&- New Romantics.m4a\n"
"/Grow - Conan Gray (Official Video) has already been recorded in archive.m4a\n"
"C:\\PowerOptim Iol/Grow - The New Gray (Official Video) has been recorded [<1999>.wm4\n"
"/Great Bun/Output Files/çè/Grow - WiLlL(O)W Gray \"unofficial\" video has not been recorded in archive.m4b\n"
"/Matter Oil_9999.zip\n"
"file:///Qpl$-pol.hrlp/perm.ui.pol/i op/matter.mp4\n"
"/£¥«^6<4>à_»Laser4 ``[12{2%}32]deg`‘.webm\n"
"manicur pliu/great.power.great.responsibility?.gz.tar.zip\n"
"./poi kiol/greater.power.greater.responsibility!.gz.tar.zip\n"
"^Level09\\Power Pol\\energy.m4a\n"
"lollller_blllade 1987 (c)/super €/music_piece_.mp3\n"
"/The 'great' solitude of zorro #12/the 退ellent urge_for.mo.tar.gz\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")