package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\W_]+`)
var str = `J&öfá___44`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}