#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([^)]+,\s\d{4}(;\s[^)]+,\s\d{4})*\)"
Local $sString = "(Palacios et al., 2014)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(a nivel fisiológico/hormonal) en chicos y chicas y se dan en ritmos de desarrollo desigual (Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Papalia et al., 2009)" & @CRLF & _
"(Martín et al., 2011)" & @CRLF & _
"(ciertas operaciones sobre las proposiciones: conjunción, disyunción…) y poner esta al servicio del recién adquirido pensamiento formal, pueden operar sobre las operaciones concretas, realizando así operaciones formales o de segundo orden (García-Madruga y Delval, 2010)" & @CRLF & _
"(García-Madruga y Delval, 2010)" & @CRLF & _
"(Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(Martín et al., 2011)" & @CRLF & _
"(es la parte que tienen afectada las personas con trastorno de déficit de atención, TDA). También se encarga de la toma de decisiones, la planificación y la regulación de la propia conducta y por esto termina de desarrollarse en la adolescencia, cuando los sujetos adquieren la capacidad de pensar sobre el pensamiento y la conducta (Goldberg, 2004)" & @CRLF & _
"(Damasio, 2010)" & @CRLF & _
"(Toro, 2010)" & @CRLF & _
"(metaoperaciones). Podrán reflexionar sobre sí mismos y sobre diferentes realidades entre las posibles (García-Madruga y Delval, 2010)" & @CRLF & _
"(Elkind, 1978)" & @CRLF & _
"(ciberacoso, divulgación de información confidencial, acoso escolar…) y poco responsables (Mariscal et al., 2009)" & @CRLF & _
"(Mariscal et al., 2009)" & @CRLF & _
"(positiva o negativa) de su desarrollo y el bienestar con su nueva realidad (Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Duke et al., 1982)" & @CRLF & _
"(Palacios et al., 2014; Pérez y Navarro, 2012)" & @CRLF & _
"(Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Martínez, 2010)" & @CRLF & _
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Martín et al., 2011)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(Palacios et al., 2014; Pérez-Pérez y Navarro-Soria, 2012)" & @CRLF & _
"(Martín et al., 2011)" & @CRLF & _
"(la adolescencia)" & @CRLF & _
"(Instagram, WhatsApp…) puede producir un sentimiento de aislamiento social (Martín et al., 2011)" & @CRLF & _
"(Oliva et al., 2002)" & @CRLF & _
"(Martín et al., 2011)" & @CRLF & _
"(ser compañeros), se hace necesaria la afinidad (Fuertes et al., 2001)" & @CRLF & _
"(afecto, apoyo…) que los chicos, tendrán redes sociales menos extensas que estos, cuyas necesidades suelen ser de logro o admiración (Martín et al., 2011)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(Furman y Wehner, 1994)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(figura 8), ya que el estilo de crianza que el adolescente ha experimentado configurará de manera decisiva la personalidad que se está formando (Palacios et al., 2014)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(Palacios et al., 2014)" & @CRLF & _
"(1936-…) propuso un modelo alternativo que diese cuenta de las diferencias de género y, tras su investigación con mujeres y niñas, encontró que, mientras que los varones estaban más interesados por el concepto abstracto de justicia, las mujeres se preocupaban más por las relaciones interpersonales y la responsabilidad a la hora de satisfacer las necesidades de los demás (Palacios et al., 2014)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")