re = /^((?:(?!<\?php echo[\s?](?:.*?)\;\s\?>).)*)<\?php echo\s(?:.*?)\;[\s?]\?>(.*)$/m
str = 'customFields[<?php echo $field[\'id\']; ?>][type]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end