package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[1-9][0-9 ().-]{5,28}[0-9])|(?:(00|0)( ){0,1}[1-9][0-9 ().-]{3,26}[0-9])|(?:(\+)( ){0,1}[1-9][0-9 ().-]{4,27}[0-9]))$`)
var str = `076 444 22 22
+ 91 45 232 45 45
00 41 12 125 1245
+1 (914) 579 45 45
914-548-2356
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}