package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<Instrument_Name>[\w]+)\\\"\s\w`)
var str = `< Instrument=\"Guitar\" Price=\"500\" >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}