$re = '/(?m)^\|\={3}[\r\n]([\s\S]+?(?=^\|\={3}[\r\n]))^\|={3}[\r\n]/m';
$str = '
[cols="1,1"]
|===
|Cell in column 1, row 1
|Cell in column 2, row 1
|Cell in column 1, row 2
|Cell in column 2, row 2
|Cell in column 1, row 3
|Cell in column 2, row 3
|===
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);