re = /(?!^)(?<!\bNo\.\s)(?<!\bQuestion\s)(?<!\d)(?!(?:19[6-9][0-9]|20[01][0-9]|2020)(?!\d))(\d+(?!\d)e?)/m
str = 'Trial No. 32819 Question 485 Article 787e
2981 XYZ Legislature
Addendum217Null'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end