$re = '/\((?:[^()]|((?R)))+\)/';
$str = 'In this (example, I want (it to recognize (each legitimate pair) of (parentheses) as a) match).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);