import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([[:alnum:]]+|\\*)\\.([[:alnum:]]+|\\*)[^[:space:]]*[[:space:]]+@";
final String string = "auth.*,authpriv.* @loghost.example.com:10514 # One \"@\" means UDP\n"
+ "*.* @@loghost.example.com # Two \"@\" means TCP";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}