$re = '/(\d+,?)/m';
$str = 'See all 200 employees
See all 2,000 employees
See all 2,000,000 employees';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);