$re = '/(?:\w+-){2}([^-.]+)/m';
$str = 'Abcd001-wd2s-vwe1-20180e3103.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);