$re = '/^(?:[A-Za-z0-9]+[-_]?)+$/m';
$str = 'this-id
this-id_98
this--id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);