$re = '/^([^"]*)\s(".*)/m';
$str = 'message "some text"
more messages "some more text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);