$re = '/(\w+),\s*(\w+)/';
$str = 'Smith, John
Smith, John
Mustermann, Max
Last,First';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);