import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Notes>(?:(?!<\\/?Notes>|sample)[\\s\\S])*sample[\\s\\S]*?<\\/Notes>";
final String string = "TextBefore<Notes>this is sample notes</Notes>TextWithsample<Notes>this is sample notes</Notes>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}