$re = '/requestType\\\\\\\\\":\\\\\\\\\"(?<requestType>\w+)/m';
$str = '{"log":"{\\\\"instanceId\\\\":\\\\"abc-fdh-48f-4432\\\\",\\\\"requestType\\\\":\\\\"ABC\\\\"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);