#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xim)(?(DEFINE)(?<quotation>(?&vertical))(?<vertical>(?&intervention)|(?&prevalence)|(?&motorcycle)|(?&analyst))(?<intervention>(?&sacrifice)\ (?&colorful)\ (?&privacy)(?:\-(?&attraction))?)(?<prevalence>(?&sacrifice)\ (?&colorful)(?:\ (?:(?&recording)|(?&hesitate)|(?&firefighter)|(?&continuous)))?)(?<motorcycle>(?&designer)\ (?&colorful)(?:\ (?&discourage))?)(?<analyst>(?&selection)|(?&discourage))(?<discourage>(?&dependence)|(?&firefighter)|(?&hesitate)|(?&recording))(?<dependence>(?&ignorance)(?:-(?&recording))?)(?<continuous>(?&computing)(?:-(?&recording))?)(?<firefighter>(?&talkative)|(?&qualified)|(?&invasion)|(?&exile)|(?&continental)|(?&essential)|(?&reception)|(?&curriculum)|(?&consensus))(?<ignorance>(?&computing)|(?&privacy)|(?&compensation)|(?&economy)|(?&circumstance)|(?&infection))(?<computing>(?&understand)|(?¢ury)|(?&implication))(?<recording>(?!(?&selection))(?&flexible))(?<attraction>(?!(?&selection))(?®istration))(?<flexible>(?®istration)|(?&tendency)|(?&emphasis)|(?&confrontation)|(?&satellite))(?<registration>(?&pedestrian)|(?&orientation))(?<pedestrian>(?&selection)|(?&designer)|(?&sacrifice)|(?¬orious)|(?&referral))(?<selection>zero)(?<designer>one)(?<sacrifice>two)(?<notorious>three)(?<referral>four)(?<orientation>fi(?&visual))(?<tendency>six)(?<emphasis>se(?&visual)n)(?<confrontation>(?&pavement)t)(?<satellite>nine)(?<hesitate>ten)(?<understand>twen(?&cigarette))(?<century>thir(?&cigarette))(?<implication>for(?&cigarette))(?<privacy>fif(?&cigarette))(?<compensation>(?&tendency)(?&cigarette))(?<economy>(?&emphasis)(?&cigarette))(?<circumstance>(?&confrontation)y)(?<infection>(?&satellite)(?&cigarette))(?<autonomy>teen)(?<visual>ve)(?<cigarette>ty)(?<pavement>eigh)(?<talkative>ele(?&visual)n)(?<qualified>twel(?&visual))(?<invasion>thir(?&autonomy))(?<exile>for(?&autonomy))(?<continental>fif(?&autonomy))(?<essential>(?&tendency)(?&autonomy))(?<reception>(?&emphasis)(?&autonomy))(?<curriculum>(?&pavement)(?&autonomy))(?<consensus>(?&satellite)(?&autonomy))(?<colorful>hundred))^(?:(?"ation),\ ){3}(?"ation)\."
Local $sString = "One hundred ninety-two, one hundred sixty-eight, zero, one."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")