import re
regex = re.compile(r"(?:(Global|Public|Private) )?(?:Const )(\w*)(?: As )(\w*)(?: = )?([\S]*)", flags=re.MULTILINE)
test_str = ("Attribute VB_Name = \"mdl_WbkInits\"\n"
"Option Compare Database\n\n"
"Public WithEvents ue_u23 As New String, soumeth_34ing as somethnig, asi As Anthere item, Maybe lastOne \n"
"Public ueu As Variant\n"
"Dim ueu\n\n"
"Public Declare Function IIDFromString Lib \"ole32\" (ByVal lpsz As Long, ByRef lpiid As UUID) As Long\n"
"Private Declare Function IIDFromString Lib \"ole32\" (ByVal lpsz As Long, ByRef lpiid As UUID) As Long\n\n"
"Private Declare PtrSafe Function FindWindowEx Lib \"user32\" Alias \"FindWindowExA\" (ByVal hWnd1 As Long, ByVal hwnd2 As Long, ByVal lpsz1 As String, ByVal lpsz2 As String) As Long\n\n"
"Private Type UUID 'GUID\n"
" Data1 As Long\n"
" Data2 As Integer\n"
" Data3 As Integer\n"
" Data4(7) As Byte\n"
"End Type\n\n"
"Public Enum e_ControlEventCatch\n"
" e_onClick\n"
" e_onChange\n"
" e_onUpdate\n"
" e_onUpdated\n"
" e_onDblClick\n"
" e_onFocus\n"
" e_onExtClick\n"
" e_onExtDblClick\n"
" e_onActivate\n"
" e_onDeActivate\n"
"End Enum\n\n"
"Public Const IID_IDispatch As String = \"{00020400-0000-0000-C000-000000000046}\"\n"
"Const OBJID_NATIVEOM As Long = &HFFFFFFF0\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")