package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) *(?:(?:([0-9]+)(?:d| ?days?)(?:, ?| )?)|(?:([0-9]+)(?:h| ?hours?)(?:, ?| )?)|(?:([0-9]+)(?:m| ?minutes?)(?:, ?| )?)|(?:([0-9]+)(?:s| ?seconds?)(?:, ?| )?))+`)
var str = `1m1d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}