package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[[:punct:]]`)
var str = `123412412!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}