$re = '/\b(?!350|380)\d{1,3}\b/';
$str = 'foo 42 bar 4242 baz 380 385
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);