re = /(\+\d{2})?[-. ]?[0-9]{3}?[-. ]?([0-9]{3})[-. ]?([0-9]{4})/m
str = '1234567890
123-456-7890
123.456.7890
+44 123 456 7890
+30 210 111 1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end