$re = '/^\s|\s$/m';
$str = ' file.ext
folder
folder
folder';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);