re = /([\u2E80-\u2FD5\u3190-\u319f\u3400-\u4DBF\u4E00-\u9FCC]+)\s+(?=[\u2E80-\u2FD5\u3190-\u319f\u3400-\u4DBF\u4E00-\u9FCC]+)/m
str = '請 把把把 這 裡 的 10 多 個 字 合 併. Can you help me?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result